#每天都是崭新的一天#再累也要照顾好自己
npm安装依赖包报错,Downloading https://chromedriver.storage.googleapis.com/2.43/chromedriver_win32.zip
发布于 作者 superadmin 648 次浏览 来自 nodejs

发现一直不走道,发现是tianchao墙了

Downloading https://chromedriver.storage.googleapis.com/2.43/chromedriver_win32.zip
Saving to C:\Users\pc\AppData\Local\Temp\chromedriver\chromedriver_win32.zip

这个时候正常上网也是没有办法去获取文件的。但是不管是那种情况,只用如下的安装命令安装完成之后,就可以继续执行npm i 或者其他的依赖包下载方式。

需要将npm的chromedriver的源地址设置为http://cdn.npm.taobao.org/dist/chromedriver

npm install chromedriver --chromedriver_cdnurl=http://cdn.npm.taobao.org/dist/chromedriver



1 回复

发现在部署centos的时候出现了问题



1、首先安装chrome

用下面的命令安装最新的 Google Chrome

yum install https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm



2、安装必要的库

yum install mesa-libOSMesa-devel gnu-free-sans-fonts wqy-zenhei-fonts



3、安装 chromedriver

将下载的文件解压,放在如下位置

unzip chromedriver_linux64.zip



使用命令将解压后的文件复制到   /usr/local/bin/chromedriver

  命令为:sudo mv chromedriver /usr/local/bin/chromedriver

  改变用户权限:

  命令为:sudo chmod u+x,o+x   /usr/local/bin/chromedriver



4、再去执行安装



发布评论
微信群
saucxs聊天机器人
saucxs
hi ,欢迎来到sau交流学习社区,欢迎与我聊天,问我问题哦!
您正在使用的浏览器是,不在支持范围内!
为了您的正常使用与展示,推荐使用Chrome浏览器68以上版本
支持浏览器:
火狐浏览器最新版
Safari浏览器最新版
Edge浏览器最新版
IE浏览器10,11